Skip to main content

Technology Services Status Dashboard

South Central Community School Corporation

Copier authentication issues

major icon Major
Copiers icon
Copiers
Identified icon Identified

Incident timeline

major icon Major

Identified - The YSoft SAFEQ software is not authenticating with users on all copiers. Support has been contacted.

Affected:
Copiers icon
Copiers